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Introduction 

What is ARCHLine.XP® 

ARCHLine.XP® is a powerful 3D BIM software for architecture, site design, interior design, and rendering. 

It includes a fully integrated Open BIM interface, giving you tools to create coordinated, computable building 

models. 

All your project elements — floor plans, sections, elevations — live in one consistent model, so you don’t need to 

manually sync anything. 

 

Architectural Design 

ARCHLine.XP® enables designing everything from single-story buildings to complex multi-level structures. 

• Draw single or multi-layered, even sloped walls in both 2D and 3D using the flexible Wall command. 

• Use parametric doors and windows that automatically update when resized. 

• Edit stairs and railings using intelligent design rules. 

• Create unique ceiling profiles (barrel vaults, cross vaults). 

• Pick from many roof styles (gable, hip, mansard, curved, etc.). 

• Use Wall Detection from point cloud data to accelerate converting surveys into BIM models. 
help.archlinexp.com 

      Tip: These intelligent tools reduce manual work and help maintain model consistency. 

 

Furnishing Spaces 

ARCHLine.XP® offers robust interior tools: 

• Lighting & shading 

• Curtains & blinds 

• Flooring, baseboards, decorative moldings 

• Suspended ceilings 

• Switches, outlets, and parametric kitchen design 

• Import objects from 3D Warehouse for rich, realistic interiors 

 

Documentation 

Use the Plan Sheet tool to produce technical documents: 

• Floor plans, elevations, sections, detailed views 

• Rendered images at various scales 

https://help.archlinexp.com/hc/en-us/articles/30990662905617-Overview
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          Note: Because everything links to a single BIM model, your documentation is always consistent and up-to-date. 

 

Visualization 

With one click, move your model into ARCHLine.XP LIVE to: 

• Create interactive walkthroughs 

• Generate high-quality render images and videos 

• Add realistic people, vegetation, water, and effects 

This creates a virtual experience — like guiding your client through their future space. 

 

2025 Innovations 

    Important: The 2025 version adds many new features: help.archlinexp.com 

• Wall Detection from Point Cloud for faster survey-to-BIM workflows.  

• Export to Revit (RVT) with full geometry and BIM data.  

• Integrated bSDD service for advanced data definitions.  

• Automatic Floor Plan Generator to speed up layout design.  

• Direct link to D5 Render for improved visualization  

• AI Render for rapid ideation & style exploration 

• New Graphical Crop view, MEP conduit support, and many interface/documentation enhancements.  

 

How to Use This Tutorial 

In this tutorial, we will guide you step by step through the process of designing a residential building. 

This material is designed to help you gain confidence and practice by working on a realistic architectural example. 

In this course, we will build the BIM modell of Bari Residential Park consisting of 4 buildings. Through this example, 

we present the process of planning a multi-story building in the ARCHLine XP BIM program. We start BIM modeling 

with ARCHLine XP CAD tools, with which we create the architectural grid, and then continue with parametric BIM 

objects, such as walls, slabs, foundation, doors, windows and stairs. Each BIM tool has its own style, which contains 

BIM-related parameters, geometry,  materials and other important settings such as layers and classifications. 

      Tip: Follow the steps in order, and try to complete each exercise. This will help you build a solid workflow. 

It is recommended to start by downloading and installing the Architectural Preliminary Course Project Installer. 

This package contains all the project files used throughout the course. 

      Tip: For the best learning experience, watch the instructional video for each workshop first. 

Then, follow the step-by-step instructions to create the design yourself in ARCHLine.XP 2025. 

 

https://help.archlinexp.com/hc/en-us/articles/30990662905617-Overview
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The course consists of 10 Workshops: 

Workshop 1 – Project Setup & Construction Grid 

• Introduction to the BIM workflow. 

• Setting up a project for 4 building locations. 

• Creating and customizing the construction grid. 

• Understanding grid spacing (equal vs. custom steps). 

• Set the Floor Structure 

 

Workshop 2 – Walls and Partitions 

• Create a multi-layer wall style 

• Draw external walls using the Wall tool with the new style 

• Add load-bearing interior walls with reference line adjustments 

• Insert partition walls (100 mm thickness) 

• Fix intersections using the X connection 

 

Workshop 3 – Slabs and Foundations 

• Define a Multi-Layer Slab Style 

• Place multi-layer slabs under walls with one click 

• Adjust slab contours in the 3D view 

• Create the foundation level and set strip footings 
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Workshop 4 – Doors and Windows 

• Set the door properties and save the door styles 

• Place different types of doors and set reference points 

• Set the widow properties and save the window style 

• Position windows in 3D view 

• Adjust distances, opening directions, and parameters 

• Animate doors in perspective view 

 

Workshop 5 – Stairs and Railings 

• Choosing a U-shaped staircase 

• Editing with the Stair Calculator (height, width) 

• Adding walls under the stair and cutting them automatically 

• Placing railings from styles 

 

Workshop 6 – Multi-Story Buildings 

• Copying entire floor plans to upper levels 

• Creating slab opening for staircase 

• Editing facade walls and balconies on the first floor 

• Adding new doors and windows on upper levels 

 

Workshop 7 – Sections & Level Parameters 

• Creating A & B section views 

• Identifying problems with wall connections 

• Adjusting Top/Bottom of Structure (TS/BS) parameters 

• Updating all walls via Style Manager 

 

Workshop 8 – Roof Terrace & Coloring 

• Copying walls and slabs to the 2nd floor 

• Converting it into a roof terrace (1000 mm wall height) 

• Applying materials and coloring walls 

• Using the “Tiling as coloring” option 
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Workshop 9 – Documentation 

• Setting up dimension styles 

• Automatic placement of room stamps 

• Applying color schemes by apartment 

• Adding callouts for detailed drawings 

• Creating elevations and Section Views 

• Plot Layouts and Printing Multi-Page PDF 

• Updating layouts automatically 

 

Workshop 10 – Environment, Rendering & Finalization 

• Adding surroundings: fences, gardens, trees 

• Saving perspective views 

• Creating photorealistic renders with background images 

• Using progressive rendering and noise filtering 

 

Workshop 11: Managing Multiple Buildings 

• Copying and placing additional buildings (to reach 4) 

Presenting the final animation 
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1. Workshop: Project Setup & Construction Grid 

In this workshop we will go through on the next steps: 

• Introduction to the BIM workflow. 

• Setting up a project for 4 building locations. 

• Creating and customizing the construction grid. 

• Understanding grid spacing (equal vs. custom steps). 

• Set the Floor Structure 

Let's Get Started! 

First, watch the Bari Project: Project Setup & Construction Grid tutorial video. 

If you haven’t already, download and install the Architectural Preliminary Course – Workshop Projects 2025 

package. 

This contains all the projects used during the course. 

 

1.1. Start a New project / Save project 

Launching ARCHLine.XP 

When you launch ARCHLine.XP®, the Welcome Screen appears. 

Here, you can choose how to start your work. 

 

Start a New Project 

1. Click on New Project in the Welcome dialog. 

 

A new blank project opens with an empty floor plan where you can start working: 

https://www.archlinexp.com/enrollments/courses/architectural-modeling-course/downloads
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          Note: By default, during installation, ARCHLine.XP creates an ARCHLine.XP Draw folder under your computer’s 

Documents folder. 

 

 

 

Save Project 

When you create a new project, it is not saved automatically — you need to save it manually the first time. 

When saving for the first time, the program opens the Save Project dialog where you can name your project and 

choose the folder where it will be stored. 

 

1. Click Save Project on the Quick Access Toolbar. 

2. Create a new folder under ARCHLine.XP Draw\2025 using the New Folder button. 

Name it: Bari_residential_park. 

3. Open the new folder and type the filename: Bari_01. 

4. Click Save. 

From now on, clicking the Save Project button will automatically update Bari_01 with your latest changes. 

      Tip: Save your work frequently — for example, every 10–15 minutes. 

    Important: It’s a good practice to create a backup copy of your project from time to time. 
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1.2. User Interface 

Before you begin drawing, take a moment to explore the ARCHLine.XP® interface. 

Knowing the main parts of the workspace will make it much easier to follow the tutorial later. 

The interface contains the following main elements: 

• File menu (1) 

• Quick Access Toolbar (2) 

• Ribbon Bar (3) 

• View Control Bar (4) 

• Side Menu: Dashboard (5), Design Center (6), Styles (7), System Browser (8), Project Navigator (9) 

• Coordinate Bar (Status Bar) (10) 

• Drawing Area (11) 
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          Note: 

For the best learning experience, we recommend using the default layout of ARCHLine.XP®. 

If your interface looks different, click the arrow at the end of the Toolbar → choose Toolbars → Reset interface to 

factory default. 

This will restore the original layout. 

 

 

Main Interface Areas 

• Side Menu, Ribbon Bar, Drawing Area – these are the most frequently used parts of the interface. 

• Ribbon Bar – a logical, well-organized catalog of commands grouped by topic (Building, Drafting, Interior 

tools, etc.). 

Only one group is open at a time, so you always see the most relevant tools. 

• Dashboard – a customizable collection of frequently used commands related to the current view. 

You can add your own commands, assign unique icons, and quickly access favorite tools and styles with 

one click. 

      Tip: Placing your most-used commands and styles on the Dashboard saves a lot of time during daily work. 
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1.3. Basic Drafting tools, Basic Navigation, and Selection 

1.3.1.  Drawing in ARCHLine.XP® 

Before you begin, take a moment to get familiar with how drawing works in ARCHLine.XP®. In this section, we’ll go 

over the key concepts you’ll need. 

Let’s start by creating two simple lines with the Line tool. 

 

Using the Mouse – Click & Release 

In this tutorial, a click means: 

Click: Press the left mouse button once and release it right away. 

 

Drawing Lines 

1. Go to Ribbon bar → Drafting → Line. 

2. Move your mouse over the drawing area. The cursor changes shape, showing that you can now draw. 

3. Click anywhere on the left side of the drawing area to place the first point. 

4. Move the mouse to the right and click again. You’ve drawn your first line — it appears as a solid black line. 

5. Move the mouse again. The endpoint of the previous line is automatically used as the starting point of the 

next line. 

6. Click again to finish the second line. 

That’s it — you’ve created two connected lines! 

 

      Tip:  

Always use simple clicks (press and release quickly). You don’t need to hold the mouse button down. Drawing uses 

only the left mouse button, just like browsing the web or editing a Word document. 
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The drawing contains two lines and a third line has started to be drawn. 

 

Exiting the Tool 

In our example, a third line is already waiting to be drawn — but we only want two. To stop drawing, you can: 

• Press Enter: This finishes the current chain of lines. Press Enter again if you want to start fresh. 

or 

• Press ESC: This completely exits the tool. 

After exiting, you’ll see the blue guideline disappear, and the cursor returns to its normal arrow shape. 

  Remember:  

Whenever you want to stop using a tool, press the ESC key on your keyboard. 

1.3.2.  Undo and Redo 

ARCHLine.XP® automatically remembers your last 16 actions. Right now, you have made two actions by drawing 

two lines. If you want to remove the last action, use the Undo command. 

 

The “Undo” command on the Quick Access Toolbar 

 

Using Undo 

• Click Undo on the Quick Access Toolbar. The last line disappears. 

• Click Undo again, and the first line disappears as well. 

When there are no more actions to undo, the Undo button turns light grey. Remember, you can only go back 16 

steps — you cannot undo beyond that. 

Using Redo 

Redo is the opposite of Undo. It restores the actions you have just undone. 
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• The Redo button is located next to Undo on the toolbar. 

• If you go back too many steps, just click Redo to bring the lines back. 

      Tip for Small Mistakes: 

If you notice an item is in the wrong place: 

1. Press ESC to stop your current command. 

2. Click Undo as many times as needed until the drawing looks correct. 

3. If you go too far back, use Redo to restore the steps you need. 

 

Practice 

Use Undo and Redo now to remove the two lines you drew earlier and then make them reappear again. 

      Tip: Try drawing circles of different sizes to practice using the Ribbon bar → Drafting → Circle tool. 

1.3.3.  Zoom in, Zoom out and Optimal Zoom 

You can zoom in and out of your drawing using the magnifier tools on the Dashboard: 

• The first magnifier zooms the drawing out to 70%. 

• The second magnifier lets you select an area and zoom it to fill the entire drawing window. 

 

 

Using the Mouse Wheel 

There is a much faster way to zoom in and out: using your mouse wheel. 

1. Move the mouse over the 2D drawing. 

2. Scroll down to zoom out – each scroll step makes the drawing smaller. 

3. Scroll up to zoom in – each scroll step makes the drawing larger. 

      Tip:  

This works just like scrolling in a Word document, except it zooms instead of moving the page. 
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Optimal Zoom 

You can quickly reset the view so that the entire drawing fits perfectly in the window. 

 

• On the Dashboard, go to Views → Optimal Zoom and click the icon. 

• Or, double-click the mouse wheel to instantly fit the whole drawing to the screen. 

Now your entire project is visible again. 

 

Why the Drawing "Moves" 

When you zoom, it may look like the drawing is “sliding” off the screen. 

          Note:  

This happens because the zoom center is always the mouse position. When you scroll, the software zooms in or 

out relative to where the cursor is. 

    Important:  

If you want to focus on a specific point, make sure your mouse is directly over it before zooming. 

 

Zooming Into a Specific Area 

1. Move the cursor to the corner where the two lines meet. 

2. Scroll up with the mouse wheel to zoom in. 

3. If the corner moves away, reposition the mouse over it and scroll up again. 

4. When you are done, double-click the mouse wheel again to reset to Optimal Zoom. 

      Tip: This way, you can completely control which part of the drawing is magnified. 

 

Panning the Drawing 

Sometimes you need to move the 2D drawing — just like sliding a sheet of paper around on your desk.  

This is called panning. 

 

Panning with the Mouse Wheel 

1. Move the mouse over the drawing. 

2. Press and hold the mouse wheel (middle button). 

3. While holding it, move the mouse left, right, up, and down. 

Watch how smoothly the drawing moves. 

4. Release the wheel — the drawing stays where you placed it. 
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     Tip: This is the fastest way to look at different parts of your drawing without zooming in or out. 

 

Summary of Mouse Wheel Functions 

• Scroll up = Zoom in 

• Scroll down = Zoom out 

• Double-click the mouse wheel = Optimal Zoom 

• Hold down the mouse wheel and drag = Pan the drawing 

          Note: Once you get used to these actions, you’ll navigate around your drawings much faster. 

 

1.3.4. Simple Selection and Delete 

It’s important to know how to delete a specific item in your drawing. 

In this example, we want to remove only the first line while keeping the second one. 

Simple Selection 

1. Move your mouse over the first line. 

2. Click once. 

The program highlights the selected element and displays small colored icons (called markers) around it. 

Markers let you perform common actions directly, without opening menus or toolbars. 

You’ll also see a floating icon menu with more options, like editing properties or deleting the item. 

Item properties are shown on the Dashboard. 

 

 

Delete 

1. Click the  Delete icon in the floating menu – the line disappears. 
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      Tip: You can use the floating menu for other quick actions, like changing properties. 

 

Undo 

1. Click Undo – the deleted line reappears. 

          Note: Undo is very useful when you accidentally delete or modify something. 

 

1.3.5.  Select Multiple Items 

When editing, you often need to select more than one item at once. 

If you just click a new item, the previous selection disappears. 

To select multiple items at the same time, use the CTRL key. 

Multiple Selection 

1. Select the first line. 

2. Hold down CTRL on your keyboard. 

3. Click the second line. 

4. Release CTRL – now both lines are selected. 

      Tip: Use this method to select any combination of items for editing or deleting. 

 

1.3.6.  Selection by Rectangle 

You can also select multiple items by dragging a selection rectangle. 

Left-to-Right Selection (Blue Rectangle) 

1. If a command is active, press ESC to close it. 

2. Click on a blank area in the upper-left corner of the drawing. 

3. Move the mouse down and to the right to create a blue semi-transparent rectangle. 

4. Click again to finish the selection. 

Result: Only the elements completely inside the blue rectangle are selected. 
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Selection by rectangle from left to right – we deliberately left out the bottom part of the drawing. 

Right-to-Left Selection (Green Rectangle) 

1. Press ESC to end the previous selection. 

2. Click on a blank area in the bottom-right corner of the drawing. 

3. Move the mouse up and to the left to create a green semi-transparent rectangle. 

4. Click again to finish the selection. 

Result: All elements inside or intersecting the green rectangle are selected. 

    

Selection from right to left. We left out the top part of the drawing. 

 

Comparison 

• Left to right (Blue): Selects only elements fully inside the rectangle. 

• Right to left (Green): Selects elements inside or crossing the rectangle edges. 

      Tip: 

• Use left-to-right selection when you want to isolate items precisely. 

• Use right-to-left selection to catch everything in an area, even if it is partly outside the rectangle. 

 

1.3.7.  Selection by Type 

You can select all items of the same type with one click: 

1. Right-click on the item type icon in the Ribbon bar (for example, Line). 

2. Choose Select all – all items of that type are selected in the drawing. 

Exercise: 

• Right-click the Line icon in the Ribbon bar. 

• Click Select all – now all lines are selected. 

• Use the  Delete icon to remove all lines, circles, and other selected items. 
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1.3.8.  Direction Enforcement – Angular Attraction – Shift 

When drawing, Ortho Mode constrains the second point relative to the first point, snapping it to the nearest fixed 

angle. 

The default angles are 0°, 45°, 90°, 135°, 180°, 225°, 270°, 315°. 

      Tip: 

The easiest way to enable Ortho Mode is to hold down the SHIFT key. 

While holding SHIFT, your cursor locks to the nearest predefined direction (horizontal, vertical, or diagonal). 

Release SHIFT to continue drawing freely. 

 

1.4. Create Construction Grid 

Now we begin building the Bari Residential Park project using the 2D construction grid. 

First, we will specify the grid distances that will later serve as a reference for drawing the exterior walls. 

In the Grid Properties dialog, you can define the grid either with uniform steps (equal spacing) or with custom step 

values horizontally and vertically. 

In this exercise, we will use custom step values. 

Steps to Create the Grid 

2. Go to Ribbon bar → Drafting → Construction Grid → Grid Setting. 

 

3. Set the parameters as shown in the figure:  

Number of lines: Horizontal = 9, Vertical = 7 

4. Switch off the Uniform Steps option. 
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5. Click Step in Horizontal Direction and enter the following values (in mm) using the Insert button: 

1400, 3600, 2500, 2500, 2500, 2500, 3600, 1400 → Click OK 
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6. Click Step in Vertical Direction and enter the following values: 

1400, 3600, 5000, 5000, 3600, 1400 → Click OK 

 

7. Place the construction grid in the center of the drawing by typing the coordinate: 

0,0 

  

 

1.5. Set the Floor Structure 

In our example, the building has 4 floors. We will first define these levels in the project. 

In architecture, floors (or levels) represent the horizontal planes of a building. 

Each level defines the reference height for elements such as walls, columns, roofs, slabs, and ceilings. 
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Just as in reality a building is constructed floor by floor, in ARCHLine.XP® the plan is also organized floor by floor. 

When you open a new project, four floors are automatically created. Additional floors can be added later 

according to the needs of the design. 

 

Navigating Between Floors 

• In the Dashboard, use the blue arrows to move up or down between the floors of the active building. 

• You can also use the blue arrows or the drop-down list in the status bar to switch levels. 

• The arrow buttons move the floor plan view one level up or down. 

• The drop-down list allows you to directly select the active floor. 

    

      Tip: Quick navigation between floors helps you work faster when editing multi-storey buildings. 

 

Edit Levels Dialog 

1. Click on the Floor button (e.g., Ground Floor) to open the Edit Levels dialog. 

 

2. Set the height of the basement to 750 mm. 

3. Add one more floor using the first icon in the dialog. 

4. Rename the floors according to the figure below. 

          Note: Consistent floor naming (Ground Floor, 1st Floor, 2nd Floor, etc.) ensures clarity in drawings and 

documentation. 
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    Important: Always check that the floor heights match the structural design before continuing with walls and 

slabs. 

   Remember: The floor structure defines the backbone of your building model — all architectural elements will 

be placed relative to these levels. 

   Remember: Save your project on the Quick Access Toolbar to preserve your project before moving on to the 

next steps. 
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2. Workshop: Walls and Partitions 

We will design the walls using the architectural grid.  

In this workshop, we will go through the following steps: 

• Create a multi-layer wall style 

• Draw external walls using the Wall tool with the new style 

• Add load-bearing interior walls with reference line adjustments 

• Insert partition walls (100 mm thickness) 

• Fix intersections using the X connection 

2.1. Define Multi-Layer Wall Style 

Next, we will draw the external walls using the wall styles 

Walls are organized into styles – each style has a predefined 

thickness and materials assigned to its layers. 

Wall styles can be single-layer or multi-layer. 

      Tip: Multi-layer wall styles allow you to design realistic 

building envelopes (e.g., brick + insulation) that are easier to 

document later. 

In this example, instead of a single-layer wall, we will create a 

simple multi-layer wall style with: 

• Layer 1: Brick – 300 mm thick, 2700 mm high 

• Layer 2: Thermal insulation – 100 mm thick, 2700 mm 

high 

Steps to Define the Wall Style 

5. Open Side Menu → Styles→ Architectural element → 

Wall. 

You will see both single-layer and composite wall styles 

listed. 

6. Right click on the the 1-layer 30 wide wall style and 

choose the Property. 
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The Wall Properties dialog appears. 

 

7. Set the material: 

Finish Face Exterior: Bright_white 

8. Click Compound Structure. 

The core layer (brick) is already defined — we will now add the insulation layer. 
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9. Click the + icon to add a new layer. 

• Set the material to Thermal Insulation 

• Thickness: 100 mm 

• Fill pattern: Thermo-isolation 

A Fill pattern mező felelős a layer alaprajzi megjelenéséért 

• Change the Function of the brick layer to Core Layer 

• Make the insulation layer the displayed layer by clicking the blue horizontal arrow 

 

          Note: Fill Pattern 

The Fill pattern field defines how the layer appears in the floor plan view. 

For example, set the Fill pattern to Thermo-isolation for insulation layers. 

    Important: Hatch on Section 

When selecting the material of a layer, make sure that the material has the appropriate hatch pattern assigned to 

represent it correctly in the section view. 

This can be set in the Material Properties dialog under the Hatch on Section tab. 

Example: Thermal Insulation material - Set the hatch pattern to Thermo-isolation (same as in the floor plan view). 
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10. When you are done, click OK. 

11. Save the new style: 

• Click the 1-layer 30 wide wall button, then click New 

• Enter the style name: Composite brick 300+100 

• Save it under the folder: Bari Residential Park 
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The new wall style will now appear in the Styles list and can be used in all your projects. 

 

2.2. External Walls 

Next, we will draw the external walls using the newly created Composite brick 300+100 style. 

We will use the construction grid points as reference. 

Steps to Draw the External Walls 

1. Click on the Wall Tool under Ribbon bar → Building commands. 

2. From the Style Menu, choose the Composite brick 300+100 wall style you created. 

3. Click on the following grid points in order: 

B6, C6, C7, G7, G6, I6, I4, H4, H1, F1, F2, D2, D1, B1, B4, A1, A6 

With the last click, you will close the building contour. The walls will automatically connect at the corners. 

ARCHLine.XP instantly updates the 3D model view to match your floor plan. 
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          Note: 

The wall is drawn along a blue reference line, which changes color depending on direction: 

• For vertical directions, it becomes dashed green 

• The green pencil at the end represents the endpoint of the wall 

• The orange line represents the wall’s thickness 
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Wall Reference Line 

The reference line can be positioned on the left side, center, or right side of the wall. 

 

You can switch the reference line position by: 

• Using the Draw Menu Bar → Left / Center / Right 

• Pressing F5 

• Pressing the Space bar 

      Tip: When the reference line is set to the right side and you draw counterclockwise, you can draw along the 

outer edge of the wall. 

Try switching the reference line while drawing a new wall to see how it affects the wall’s placement. 

 

2.3. Load-bearing interior walls 

After drawing the building contour, we continue with the inner load-bearing walls. 

For this, we first define a single-layer wall style and then draw the walls step by step. 

Define the One-Layer Wall Style 

1. Open Side Menu → Styles. 

2. Select the 1-layer 30 wide wall style. 

The Wall Properties dialog appears. 

3. Set the material: Finish Face Exterior: Bright_white 

4. Set the Layer: Wall – Partition wall 

5. Save the new style: 

o Click the 1 layered 30 wide wall button, then click New 

o Enter the style name: 1 layered brick 300 wide 

o Save it under the folder: Bari Residential Park 
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The new style will now be available for all projects under the Styles menu. 

 

Drawing the Walls 

Zoom in on Point 1, the starting point of the first inner wall. 

1. Click on the Wall Tool under Ribbon bar → Building commands. 

2. From the Style Menu, choose the 1 layered brick 300 wide wall style you just created. 

3. Click Point 1. 

o Make sure the reference line is set to Right. 

o If not, choose Right option from the menu. 

o Connect the wall to Point 2 and press Enter. 

Next, we start the second wall from the midpoint of the outer wall: 

4. Click Point 3 and choose Center option from the menu. 

o Connect the wall to Point 4. Enter. 

For the next walls: 

5. Click Point 4. 

o Set the reference line to Right, then connect. Enter 

6. Click Point 5. 

o Set the reference line to Left. Enter 

The program will automatically connect the walls. 
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      Tip: Switching the reference line (Left / Right/Center) ensures your walls are aligned correctly  

          Note: You can use F5 or the Space bar to quickly change the reference line direction while drawing. 

2.4. Partition walls 

Next, we continue by drawing the 100 mm wide partition walls. 

First, we define a wall style for the partitions, then we draw them step by step. 

Define the 100 mm wide Wall Style 

1. Open Side Menu → Styles. 
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2. Select the 1 layered 10 wide wall style. 

The Wall Properties dialog appears. 

3. Set the material: Finish Face Exterior: Bright_white 

4. Set the Layer: Wall – Partition wall 

5. Save the new style: 

o Click the 1-layer 10 wide wall button, then click New 

o Enter the style name: 1 layered brick 100 wide 

o Save it under the folder: Bari Residential Park 

 

The new style is now available for all projects under the Styles menu. 
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Drawing the Partition Walls 

We will draw the first partition wall at a distance of 2760 mm from the corner of the main wall. 

For this, we place a temporary reference point at the corner and measure from there. 

1. Click on the Wall Tool under Ribbon bar → Building commands. 

2. From the Style Menu, choose the 1 layered brick 100 wide style you just created. 

3. Select the Reference command from the Status Bar.  

4. Click slightly below Point 1 — not exactly on the corner point, so it’s clear which wall you are referencing. 

5. Move the mouse vertically downwards, type 2760, then press Enter. 

The program measures 2760 mm downwards from the reference point and places the starting point of the 

wall. 

6. Move the mouse horizontally. 

o Make sure the reference line is set to Left. 

o When the perpendicular point on the opposite wall is recognized, click once to place the endpoint, 

then press Enter. 

          Note: Continue drawing the remaining partition walls following the layout in the figure. 

The walls are connected automatically — except where we will use the X connection. 

 

      Tip: Using a reference point and a precise distance ensures your partitions are perfectly aligned and meet exact 

design requirements. 

    Important: Make sure the reference line is on the correct side before clicking, otherwise the wall will be placed 

incorrectly. 
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2.5. Fix Intersections Using the X Connection 

Although most walls connect automatically, some intersections need to be fixed manually. 

For this, we use the X Connection tool. 

1. Right-click on the intersection point. 

2. Choose Connection → X Connection. 

3. Repeat the same step for the second intersection. 

The walls are now properly joined and the intersection is corrected. 

      Tip: Use X Connection whenever two walls don’t meet cleanly – this keeps the geometry tidy and accurate. 
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   Remember: Using the File menu → Save project as command save your project under a new file name (for 

example, Bari_02) to preserve your project before moving on to the next steps. 
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3. Workshop: Slabs and Foundations 

We continue the design process by creating the layered slab and the foundation level. 

In this workshop, you will learn how to: 

1. Define a Multi-Layer Slab Style 

2. Place multi-layer slabs under walls with one click 

3. Adjust slab contours in the 3D view 

4. Create the foundation level and set strip footings 

5. Switch layer visibility for better editing 

 

3.1. Define Multi-Layer Slab Style 

We will draw the slab under the entire building using slab styles. 

Slabs can be single-layer or multi-layer, each with predefined thicknesses and materials. 

In this example, we will create a multi-layer slab style with: 

1. Layer 1: Reinforced concrete – 200 mm thick 

2. Layer 2: Concrete – 100 mm thick 

 

Steps to Define the Slab Style 

1. Open Side Menu → Styles → Architectural element → Slab 

Here you will see both single-layer and composite slab styles. 
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2. Right-click on 1-layered 30 r.c. slab and choose Property. 

The Slab Properties dialog will appear. 

3. Set Materials to: Concrete3, Bright white, Concrete3 

 

4. Click the Slab layers button. 

The reinforced concrete layer is already defined. 

Now add a new layer. 

5. Click the + icon to add a new layer: 

• Material: Floor Slab 01 

• Thickness: -100 mm 

• Set the reinforced concrete layer as the displayed layer (blue arrow). 

6. Change the thickness of the reinforced concrete layer to -200 mm. 
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Adjusting Section Hatching 

At this point, the hatching in section view may look incorrect. 

We must set the hatching pattern for each material. 

1. Select the Floor Slab 01 material → click the     gear icon → Edit material. 

2. In Material Properties, click Hatch on section → choose Concrete ISO. 

Adjust distance and angle as needed. 
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3. Repeat for Reinforced concrete, selecting Reinforced concrete ISO. 

  

Now the hatching will appear correctly in the section. 

4. When finished, click OK. 

 

5. Save the new style: 

o Select the 1-layered 30 r.c. style → click New 

o Enter the name: Composite concrete 200+100 
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o Save it under the folder: Bari Residential Park 

      Tip: The new style will now appear in the Styles list and can be reused in any project. 

 

3.2. Place the Slab 

Now we place the slab under the walls with just one click using the newly created Composite concrete 200+100 

style. 

1. On the Ribbon bar, go to Building → Slab → Slab by wall. 

2. Select the style: Composite concrete 200+100. 

3. Select the entire building outline (see points 1 and 2 in the 

figure below) 

 

          Note: The program automatically places the slab under the walls based on the selected style. 

The slab is now completed. 
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3.3. Adjust Slab Contours in 3D View 

To refine the slab, let’s adjust its contour in 3D. 

1. Use Cut-away 3D view by rectangle to isolate 

part of the model. 

• Draw a rectangle on the floor plan to select 

the area. 

• The Partition View will appear. 

 

 

The slab edge must not extend under the wall insulation. Instead, it should align with the load-bearing wall layer. 

2. Click on the slab → select the blue contour line → choose Offset All from the Marker menu. 

3. Move the cursor to the right and type: 100. 

  

   Remember: Adjusting slab contours ensures correct alignment with walls and avoids construction errors later. 
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The slab contour is now corrected. 

 

 

3.4. Create the Foundation Level and Set Strip Footings 

In this step, we will work with the strip footings. 

To do this, only the slab layer should remain visible. 

Layer Walk  

1. Activate the Floor Plan by clicking on its tab. 

 

2. In the Status Bar, go to Layer → Layer Walk. 

 

3. Select the Slab layer to turn off the visibility of all other layers. 

Now only the slab is visible on the floor plan. 

      Tip: Hiding unnecessary layers helps you focus on the foundation geometry without distractions. 

 

Floor Structure 

The floor structure of the building has already been defined. So far, we have been working on the Ground Floor. 
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1. Click on the Floor button (Ground Floor) to check the floor structure, then press OK. 

 

2. Now make the Basement level active while keeping the Ground 

Floor visible: 

• Click the arrow on the Floor button 

• Activate Basement 

• Set Ground Floor to Visible 
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          Note: Keeping the Ground Floor visible helps you align the foundation correctly with the slab above. 

 

Foundation / Set Strip Footings Style 

Starting from the 1-layered 30 r.c. slab, create a new strip footing style: 

• Height: 450 mm 

• Save the new style as: Concrete 450 foundation 

    Important: Always create a dedicated foundation style to ensure consistent thickness and material settings 

across the project. 

 

 

Draw Foundation 

1. On the Ribbon bar, go to Building → Slab → Closed foundation. 

2. Set the thickness to 300 mm. 

3. Select the Concrete 450 foundation style from the Styles tool. 

(You may need to set the thickness again.) 

4. Follow the slab contour by clicking on the edges of the slab above (one level higher). 

   Remember: The reference line of the foundation must be set. 

Press F5 or Space to switch and use the correct reference side. 

 



52 Workshop 3: Slabs and Foundations 

Architectural Intermediate Tutorial 

 

 

 

Draw Other Strip Footings 

Now, let’s create the additional strip footings under the load-bearing walls. 

1. Use the Layer Walk icon to turn on the layer of the load-bearing walls. 

2. On the Ribbon bar, go to Building → Slab → Open foundation. 

3. Set the thickness to 300 mm. 
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4. Follow the load-bearing wall lines by clicking on their edges. 

   Remember: Again, set the reference line properly (F5 or Space key) to ensure correct placement. 

5. Finally, switch off the visibility of the Ground Floor. 

 

 

   Remember: Save your project under a new file name (for example, Bari_03) to preserve your project before 

moving on to the next steps. 
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4. Workshop – Doors and Windows 

Let’s continue the design by placing the doors and windows, which are also BIM parametric objects. 

In this workshop, you will learn how to: 

• Set the door properties and save the door styles 

• Place different types of doors and set reference points 

• Set the widow properties and save the window style 

• Position windows in 3D view 

• Adjust distances, opening directions, and parameters 

• Animate doors in perspective view 

In this project we will use these five door types and one window type: 

1. Internal door 

2. One-leaf balcony door 

3. Three-leaf balcony door 

4. Staircase entrance door 

5. Entrance door 

  

6. Double leaf window 
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4.1. Set Door Properties 

4.1.1. Internal Door 900x2100 

First, we will set the properties of the Internal door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Door.  

2. In the Property Window, choose the door type: 

• Click on the Flash (Door type). 

• Select: Doors → Indoor → Single → Full Int 1. 

 

Adjusting Parameters 

3. Distance from wall line: 0 mm 

4. Solid material: Dark gray (or black)  

•           Note: When the Material category is active, type black in the search field.  

Select the Black color. 

• Click on the gear icon     and create a new material based on the black color: 

Dark Gray (RGB: 52, 52, 52). 
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      Tip: Creating your own custom material ensures a consistent look across all doors in the project. 

 

Saving the Style 

1. Click on the Style button (Normal door). 

2. Save the style under the name: 

Internal door 900×2100 gray 

3. Save it in the folder: Bari Residential Park. 

4. Press OK, then OK again. 
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The new internal door style has been created successfully. 

 

          Note: 

After setting the parameters of the openings, it is recommended to save them as a style and then place the 

elements in the project. 

However, this is not mandatory: you can also work without using styles by setting the parameters and placing the 

openings directly. 

Using styles is especially useful in larger projects, as it makes the design process faster, more consistent, and easier 

to manage. 

 

4.1.2.  One-leaf Balcony Door - 900x2400 

We will set the properties of the one-leaf balcony door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Door.  

2. In the Property Window, choose the door type: 

• Click on the Full int1 (Door type). 

• Select: Doors → Indoor → Single → Full Lite. 
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Adjusting Parameters 

1. Set the Basic geometry as shown in the figure:  

2. Set the Main parameters: 

• Height: 2400 mm 

• Distance from wall line: 100 mm 

• Solid material: Dark gray  
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Saving the Style 

1. Click on the Style button. 

2. Save the style under the name: 

One-leaf balcony door 900×2400 gray 

3. Save it in the folder: Bari Residential Park. 

4. Press OK, then OK again. 

The new balcony door style has been created successfully. 

 

4.1.3. Three-leaf Balcony Door - 2700x2400 

We will set the properties of the multiple-leaf balcony door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Door.  

2. In the Property Window, choose the door type: 

• Click on the Full lite (Door type). 

• Select: Doors → Indoor → Double → Multiple glass. 
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Adjusting Parameters 

1. Set the Basic geometry as shown in the 

figure:  

2. Set the Main parameters: 

• Width: 2700 mm 

• Height: 2400 mm 

• Thickness: 150 mm 

• Solid material: Dark gray  
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Saving the Style 

1. Click on the Style button. 

2. Save the style under the name: 

Three-leaf balcony door 2700×2400 gray 

3. Save it in the folder: Bari Residential Park. 

4. Press OK, then OK again. 

 

4.1.4. Staircase Entrance Door - 3600x2550 

We will set the properties of the staircase entrance door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Door.  

2. In the Property Window, choose the door type: 

• Click on the door type. 

• Select: Doors → Outdoor → Glass → Double leaf glass door with frames. 
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Adjusting Parameters 

1. Set the Basic geometry as shown in the figure:  

2. Set the Main parameters: 

• Width: 3600 mm 

• Height: 2550 mm 

• Thickness: 50 mm 

• Solid material: Dark gray  
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Saving the Style 

3. Click on the Style button. 

4. Save the style under the name: 

Staircase entrance door - 3600x2550 

5. Save it in the folder: Bari Residential Park. 

6. Press OK, then OK again. 

 

4.1.5. Entrance Door - 1100x2100 

We will set the properties of the entrance door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Door.  

2. In the Property Window, choose the door type: 

• Click on the door type. 

• Select: Doors → Indoor → Paneled → Door with 3 square glass insets  
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Set the Main parameters: 

• Width: 1100 mm 

• Height: 2100 mm 

• Thickness: 100 mm 
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Saving the Style 

1. Click on the Style button. 

2. Save the style under the name: Entrance Door - 1100x2100 

3. Save it in the folder: Bari Residential Park. 

4. Press OK, then OK again. 

Now all five door styles have been created successfully. 

 

 

  



 Workshop 4 – Doors and Windows 67 

  

4.2. Placing Doors 

Let's continue the design by placing the doors.  

Doors can be selected either from the Design Center or from the Door Styles panel. 

• In the Design Center, various types of doors are organized. 

• From the Style Tool, you can access and use the door styles that were created earlier. 

After placing a door, you can: 

• Set its opening direction 

• Adjust its size 

• Modify a parameter to display it as open or closed 

          Note: 

All door parameters remain editable even after placement. 

 

4.2.1.  Place the Three-leaf Balcony Doors 

Let’s start with the three-leaf balcony door. 

Before placing it, we will change the reference point to ensure the door is positioned correctly relative to the 

corner. 

The distance from the wall corner will be 100 mm, and we will place four doors of this type. 

 

Steps to Place the Door 

5. Go to the Ribbon Bar → Building → Door → Placing Door command. 

6. From the Style Tool, select the Three-leaf Balcony Door style. 
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7. Click on the internal side of the wall — a preview of the door will appear. 

  

1. During placement, switch the reference point using New Reference Point from the View Control Bar (or 

press F5 or the Spacebar) twice so you can position it with the left reference point. 

2. Set the distance from the wall corner to 100 mm. 

3. Define the opening direction, then press Enter. 

4. Continue to place the remaining three doors of the same type. 

5. Press Enter again to close the command. 

          Note: 

While the Door Placement command is active and the Style is selected, it’s enough to: 
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• Click on the internal side of the wall, 

• Change the reference line, and 

• Type the distance (100 mm). 

          Note: 

Doors automatically cut through the wall thickness and are automatically aligned to the floor level. 

 

 

4.2.2.  Place One-leaf Balcony Doors 

Let’s continue with the One-leaf Balcony Door. 

The distance from the wall corner will be 400 mm, and we will place four doors of this type. 

Steps to Place the Door 

1. Go to the Ribbon Bar → Building → Door → Placing Door command. 

2. From the Style Tool, select the One-leaf Balcony Door style. 

3. Click on the internal side of the wall — a preview of the door will appear. 

4. Switch the reference point to position it using the right reference point. 

5. Set the distance from the wall corner to 400 mm. 

6. Define the opening direction, then press Enter. 

7. Continue to place the remaining three doors of the same type. 

8. Press Enter to close the command. 

      Tip: 

When placing the fourth door, you can simply place it on the wall as desired, then adjust the distance from the 

corner and change the opening direction afterwards if necessary. 
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4.2.3. Place the Entrance Doors 

Let’s continue with placing the entrance doors located in the 

staircase area. 

The distance from the wall corner will be 100 mm (or 200 mm, 

depending on the wall layout), and we will place four doors of this 

type. 

Steps to Place the 1st Entrance Door 

1. Go to the Ribbon Bar → Building → Door → Placing Door 

command. 

2. From the Style Tool, select the Entrance Door style. 

3. Click on the side of the wall where the door should be 

placed. 

4. Switch the reference point to position it using the right 

reference point. 

5. Set the distance from the wall corner to 100 mm. 

6. Define the opening direction, then press Enter. 

7. Continue to place the remaining three doors of the same 

type according to the layout shown in the figure. 

8. Press Enter to close the command.  

   Remember: Doors can be repositioned, and their properties and opening directions can be modified at any 

time — even after placement. 
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4.2.4.  Place the Staircase Entrance Door 

Let’s continue by placing the building’s main door, also known as the staircase entrance door. 

This door will be positioned in the middle of the wall to create a balanced and symmetrical entrance. 

Steps to Place the Staircase Entrance Door 

1. Go to the Ribbon Bar → Building → Door → 

Placing Door command. 

2. From the Style Tool, select the Staircase 

Entrance Door style. 

3. Click on the internal side of the wall where 

the door should be placed. 

4. Switch the reference point to position it 

using the Internal reference point. 

5. Move the cursor to the midpoint of the wall side and click to place the door 

6. Define the opening direction, then press Enter. 

7. Press Enter to close the command.  

   Remember:  

Doors can be repositioned, and their properties and opening directions can be modified at any time — even after 

placement. 

      Tip:  

By clicking on the door (either in the Floor Plan or in the 3D view), you 

can open it by typing the desired opening angle in the marker menu. 

 



72 Workshop 4 – Doors and Windows 

Architectural Intermediate Tutorial 

 

 

4.2.5. Place the Internal Doors (Independent Exercise) 

Finally, we will place all the internal doors on the Ground Floor of the building. 

This task is an independent exercise, allowing you to apply everything you have learned so far about door 

placement, reference points, and alignment. 

The figure below will help you identify the correct door locations and opening directions. 

 

      Tip: 

Follow the same workflow as before — choose the proper door style, set the reference point, and define the 

correct distance from walls or corners for precise placement. 

          Note: 

Place the remaining balcony doors according to the layout shown in the figure. 

Now we can see all the doors placed on the Ground Floor and in 3D view: 
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4.3. Set Window Properties - Double Leaf Window 

First, we will set the properties of the window. 

The process of setting the window properties is the same as for the doors. 

In this example, we will use one type of window: 

Double Window 1500×1500 gray 

Steps to Set the Window Properties 

We will set the properties of the staircase entrance door. 

1. Go to the Ribbon Bar → Building → Properties → Openings → Window.  

2. In the Property Window, choose the window type: 

• Click on the window type: Flush 

• Select: Window → Standard → Double → Equal div.2. Press OK 
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Adjusting Parameters 

3. Set the Basic geometry as shown in the figure:  

4. Set the Main parameters: 

• Width: 1500 mm 

• Height: 1500 mm 

• Thickness: 100 mm 

• Distance from wall line: 100 mm 

• Solid material: Dark gray  

5. Set the Internal and External Sill parameters: 

• Choose Imperial_white marble material for both Internal and External Sill 

 



76 Workshop 4 – Doors and Windows 

Architectural Intermediate Tutorial 
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Saving the Style 

6. Click on the Style button. 

7. Save the style under the name: Double Window 1500x 1500 gray 

8. Save it in the folder: Bari Residential Park. 

9. Press OK, then OK again. 

The new double window style has been created successfully.  

 

 

 

4.4. Placing Windows in 3D 

Windows can also be selected from the Design Center or from the Window Styles. 

Now we will place the window in 3D view by dragging it onto the appropriate wall surface and specifying the 

distance from the corner point. 

Steps to Place Double Leaf Window in 3D 

1. Activate the 3D view clicking on the View2 

Tab  

2. Go to the Ribbon Bar → Building → Window → Placing Window command. 

3. From the Style Tool, select the Double window 1500x1500x gray style. 

4. Click on the appropriate wall side — a preview of the window will appear. 

   

5. Switch the reference point (using F5 key) to position from the left wall corner. 

6. Type the distance from the wall corner to 1900 mm. 
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Continue placing the second window: 

7. Click on the appropriate wall side and simply place it on the wall as 

desired. Later you can adjust the distance from the corner later. 

Please avoid the internal wall connection when placing. 

8. Press Enter to close the command. 

9. Click on the second window, then click on the right-side distance 

marker and type the distance from the wall corner: 600 mm 

  

 

10. Press Esc to close the selection. 

Continue to place all the windows that appear on the floor plan below: 
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Now we can see all the openings placed on the Ground Floor. 

 

4.5. Visualization: Perspective View and Animation 

Let’s take a look at our work so far. 

Switch to Perspective view, rotate around the target point, and open the staircase entrance door using animation. 

 

Axonometric Views 

So far, we have been working in axonometric view. 

Make sure the 3D view is active and that no element is selected. 

At this point, you can choose between different axonometric views on the Dashboard — try them out! 
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4.5.1.  Setting up the perspective view 

Now let’s set up a perspective view. 

A perspective view is defined by specifying the camera position 

(Viewpoint), the target position (Target point), and the camera angle. 

1. On the Dashboard, click the Perspective View → Eye icon. 

In the Perspective dialog, the model is displayed in top view. 

We recommend switching to the floor plan view for easier setup: 

2. Click on the 2D View (1) button – the top view is replaced by the Ground Floor plan. 

3. Press the Fit to view (2) button. 

4. Click and hold the Camera point (3) and move it to the desired position. 

5. Click and hold the Target point (4) and move it to the center of the model. 

 

1.  Adjust the Camera height and Target height to 1400 mm, 

and set the angle to 60°. 

2. Save this perspective by clicking the green plus (5). 

The program saves the view as View_00. 

3. Double-click the view name. In the dialog box that appears, 

rename it to Entrance view 1, then press OK. 

4. Press OK again to close the dialog. 

The first perspektív view is ready. 

Create two more perspectives based on the figures provided.  
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          Note: For the External view 1, set the Camera height to 10,000 mm.

  

      Tip: Perspective views can be selected in several ways: 

• From the Dashboard (by name or using the blue arrows), 

• From the Status bar (by name or blue arrows), 

• Or by pressing the Page Up and Page Down keys on the keyboard. 
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Quick Perspective Views 

After creating perspective views, an additional icon appears on the 

Floor Plan. 

This allows you to set up Quick Perspective Views directly from the 

plan. 

The camera icon shows what you would see from the camera’s 

position. 

You can move the camera icon by dragging the circle, and you can 

rotate it by dragging the triangle, which adjusts the field of view. 

 

 

4.5.2. Animation 

Rotate the model 

In the next step, we will rotate the model around the Target point. 

1. Make sure the 3D view is active and choose the External perspective 1. 

2. Go to the Ribbon Bar → View → Animation → Walk and Fly → Rotate around. 
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The model will rotate around the Target point. 

Press any key to stop the rotation. 

      Tip: Independent Exercise 

Try out the other commands in the Walk and Fly menu as well. 

 

Open the Staircase Entrance Door Using Animation 

1. Make sure the 3D view is active and choose the External perspective 1. 

2. Click on the door, then click on the opening marker. 

The door opening animation will start automatically. 

  

Now the model is ready with all doors, windows, and perspective views created. 

 

Practice Task – Individual Work 

To prepare for the next Stair workshop, set up the staircase area 

by drawing two new walls with a thickness of 200 mm. 

1. Create a new wall style based on 1 layered brick 100 

wide, and name it 1 layered brick 200 wide. 

2. Then, draw the two walls using the dimensions shown 

in the figure. 

   Remember: Save your project under a new file name (for 

example, Bari_04) to preserve your project before moving on to 

the next steps. 
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5. Workshop 5 – Stairs and Railings  

In this workshop, we will create a U-shaped staircase connecting the Ground Floor and the First Floor. 

We will edit its geometry, set the correct heights, add supporting walls underneath, and place a railing. 

• Choosing a U-shaped staircase 

• Editing with the Stair Calculator (height, width) 

• Adding walls under the stair and cutting them automatically 

• Placing railings from styles 

5.1. Understanding Stairs in ARCHLine.XP 

The stair tool in ARCHLine.XP is a powerful and flexible feature designed to create stairs quickly and precisely for 

both architectural and interior design projects. 

It offers a variety of methods and styles — from simple straight stairs to complex U-shaped, L-shaped, or curved 

designs — and allows you to control every geometric and visual aspect of the stair. 

ARCHLine.XP provides several ways to define a staircase: 

• Using predefined stair types, then setting the desired parameters. 

• Graphically, by defining the staircase boundary — clicking points on the floor plan to shape and size the 

stair. 

• Step-by-step, based on an existing staircase. (Ideal for reconstruction or surveying old buildings.) 

 

The Logic Behind the Stair Tool 

When you start creating a stair, ARCHLine.XP generates a 3D parametric object that automatically connects two 

building levels. 

The floor height difference determines the total stair height, while the program calculates the number of risers 

and treads to meet ergonomic standards. 

The Stair Calculator is the main control panel for this process. Here, you can: 

• Modify the riser height, tread depth, and stair width 

• Adjust landing size, turn type, and support options 

• Define whether the stair should cut walls below 

• Customize the 2D symbol and 3D material appearance 

          Note: ARCHLine.XP continuously checks stair ergonomics. 

If a design exceeds comfort limits (for example, the stair is too steep or too shallow), the software highlights the 

parameter in red, alerting you to adjust dimensions as needed. 

 

Smart Integration with the Building Model 

One of ARCHLine.XP’s key strengths is the intelligent interaction between the stair and the rest of the model. 
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• When placed between levels, the stair automatically adapts to the floor height difference. 

• When positioned above walls, activating “Cut the walls – Own floor and below” makes the stair cut those 

walls automatically in 3D. 

• You can also add railings, handrails, or walls under the stair, which will follow its slope automatically. 

   Remember: All stairs in ARCHLine.XP are intelligent BIM objects, meaning they remain editable, maintain level 

connections, and appear automatically in sections, elevations, and schedules. 

 

5.2. Choosing and Placing a Stair 

1. Activate the Ground Floor by clicking on the Ground Floor View tab. 

2. Go to Building → Stair on the Ribbon. 

3. Choose U-shaped Stair from the available types. 

 

The cursor now takes the shape of the stair. 

4. Define its position graphically: 

• Move the cursor to the first point shown in the figure. 

A green dashed horizontal line appears, helping you define the 

next point. 

• Click the second point where the green line intersects the wall. 

• Then click the third and fourth points, and finally click again 

on the first point to close the shape. 

The stair appears automatically using default parameters. You can modify 

its dimensions later in the Stair Calculator. 
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      Tip: Press F5 or the Space bar before placement to set the reference point of the stair (for example, “At left 

side” or “At center”). 

This makes it easier to align the stair precisely with nearby walls. 

 

Creating a Partial 3D View 

To see the stair more clearly in 3D, let’s create a Partition View. 

1. On the Status Line, choose Rebuild 3D → Cut Away 3D View by Rectangle. 

2. Define the cutting rectangle so that it slices through the stair. 

This creates a 3D section view showing only the stair area. 

 

 

 



88 Workshop 5 – Stairs and Railings 

Architectural Intermediate Tutorial 

Editing Stair Parameters - Stair Calculator Dialog 

In the Partial View, you can see that the stair does not yet reach the next floor level. 

We will correct this using the Stair Calculator. 

1. Activate the Partial View. 

2. Select the stair and click the Pencil icon to open the Stair Properties dialog. 

3. Choose the Stair Calculation tab. 

4. Adjust the following values: 

• Unlock the three padlocks 

 

• Height: Set to 3000 mm, corresponding to the floor level difference, then close the padlock. 

• Choose the first icon on the right side — this means the last step reaches the slab level. 

The stair calculator warns you with red fields that the stair is not yet ergonomic. 
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• Number of steps: Type 9 + 9 = 18. 

• Flight width: Change to 1100 mm. 

• Lock the padlocks again in the Step Geometry section. 

 

• Path position: Keep it at 50% for a central walking line. 
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          Note: The Stair Calculator continuously checks ergonomic proportions and displays any non-compliant values 

in red for easy identification.

 

Adjusting 3D Representation 

1. Under the Support tab, enable Cut the walls – Own floor to allow the stair to cut the walls automatically. 

2. Set the Waist slab material to Concrete 3. 

3. Set the Tread material to Imperial White. 

 

 

The stair now reaches the first floor correctly. 
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5.3. Adding Walls Under the Stair 

1. On the Ground Floor plan, draw the walls under the stair using the 1 layered brick 200 wide wall style. 

2. When the stair overlaps them, ARCHLine.XP automatically cuts the walls along the stair’s slope. 

    Important: 

• Ensure that the wall and stair heights are consistent to display accurate cutting in 3D. 

• Make sure that the starting point of the first wall coincides with the starting point of the stair flight, not 

with the nosing line.  

If you set the Line width scale to 1:1, the starting point will be displayed more precisely. 

  

 

 

5.4.  Adding a Railing 

1. Select the stair and click the Pencil icon to open the Stair Properties dialog. 

2. Choose the General → Railing. 
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3. Place the railing on the right side only. 

4. Select a suitable railing style from the library: Steel profile - right. 

          Note: You can detach the railing later for individual editing or design customization. 
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Result: 

You have created a U-shaped stair with accurate geometry, automatic wall cutting, and a custom railing — fully 

integrated into the BIM model. 

   Remember: Save your project under a new file name (for example, Bari_05) to preserve your project before 

moving on to the next steps. 
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6. Workshop: Multi-Story Building 

We want to develop the project into a multi-storey building. 

In this chapter, we will cover the following topics: 

• Copying entire floor plans to upper levels 

• Creating slab opening for staircase 

• Editing facade walls and balconies on the first floor 

• Adding new doors and windows on upper levels 

      Tip: This workshop focuses on extending your project vertically — learning how to manage and modify multiple 

building levels efficiently. 

 

6.1. Copying Elements to the First Floor 

We will start by creating the first floor from the existing ground floor layout. 

To do this, we’ll use the Copy Level command to duplicate all building elements to the upper level. 

 

Steps to Copy the Ground Floor 

1. Select the Ground Floor tab to make the ground floor active 

 

2. Select all elements on the ground floor (except the architectural grid). 

3. Click the Floor button – the Edit Levels dialog appears. 

4. Choose the Copy Objects to Other Floor icon. 

5. Set the target level to “1st Floor”. 

6. Click OK to complete the copy. 

      Tip: The Copy objects to other floor function automatically duplicates the selected elements — including walls, 

slabs, doors, and windows — maintaining their correct positions between levels. 
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Checking the Result 

After copying, the 1st Floor plan view become active. 

You will see that all architectural elements from the ground floor are now duplicated. 
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          Note: Some elements, such as staircase openings (slab holes), may need to be adjusted manually on the new 

level. 

 



98 Workshop 6: Multi-Story Building 

Architectural Intermediate Tutorial 

 

 

6.2. Creating the Staircase Opening 

At this point, the staircase opening is missing from the first-floor slab. 

Let’s fix this before continuing. 

1. Switch to the Partial view. 

2. Delete two unnecessary walls under the stair. 

    

3. Switch back to the 1st Floor view. 

4. Select the slab by clicking on its contour. 

If there are multiple overlapping elements on the plan, use the Selection List to pick the correct one. 
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5. Once the slab is selected, click the arrow on the floating toolbar. 

6. From the pop-up menu, choose Hole → Create Hole. 

 

Draw a rectangular contour to define the slab opening as shown in the image below. 

  

The staircase opening is now complete, allowing vertical connection between floors. 

    Important: Always double-check that the opening aligns precisely with the stair position below to avoid 

mismatched geometry in 3D. 



100 Workshop 6: Multi-Story Building 

Architectural Intermediate Tutorial 

6.3. Modifying the First-Floor Model 

Now that the first floor has been created, we will make some 

adjustments to its layout and façades. 

To do this, we first delete the balcony doors. 

After that, we will modify the facade walls on the floor plan. 

Before starting, turn off the visibility of the Architectural Grid layer, 

as we no longer need it for this stage of the work. To do this, make 

sure that the floor plan view is the active window before changing 

the layer visibility. 

 

 

 

 

 

 

6.3.1. Delete the balcony doors 

1. Switch on the 3D View. 

2. Delete the balcony doors that are not required on this floor. 
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6.3.2. Editing the Walls and Slab 

1. Make sure the 1st Floor View is active. 

2. Select the wall and move it 3000 mm to the 

right. 

3. Cut the left wall using a line, 2500 mm from 

its left endpoint, by applying the Reference 

Point option from the Status Bar. 

 

4. Move the first wall segment downward by 1400 mm. 

 

5. Using the Create Similar command, connect the previous two wall segments with the same wall type. 

  

6. Move the left corner point of the slab and delete the other two corner points to match the new wall 

layout. 
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          Note: Adjusting the slab corner ensures proper alignment between the wall and floor edges in both plan and 

3D views.

 

6.3.3. Placing Windows and Balcony Doors 

Next, switch to the 3D view to place new openings. 

1. Select the left-side window and use the Create Similar command to insert new windows at the desired 

positions. 

2. Modify their distance from the wall corner to 500 mm. 

     

3. Add two balcony doors where required. 

If necessary, change the reference point before placement — just as you did earlier on the floor plan. 
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      Tip: Changing the reference point helps when placing mirrored or symmetrically positioned elements on 

facades. 

 

6.3.4. Defining and Placing Balcony Wall 

 In the next step, we will create a 1,000 mm high composite balcony 

wall style and place it on the balcony. 

Steps to Define the Balcony Wall Style 

1. Open Side Menu → Styles→ Architectural element → Wall. 

2. Right click on the the Bari Residental Park / Composite brick 

300+100 wide wall style and choose Property. 

The Wall Properties dialog appears. 

3. Click on the Compound Structure button. 

4. Change the thickness of the brick layer to 200 mm. 

5. Edit the height of both layers by clicking Edit. 

 

6. Change the Top bound to Unset and set the Normal height to 1000 mm. Press OK. 
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      Tip: Setting the top bound to Unset allows you to define a custom wall height independent from the story level. 

See the result in the image below, then press OK. 

 

7. Turn on the Disallow wall joins option. 

8. Save the new wall style with the name: Composite brick 200+100 wide 1000 height no connected 
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9. Draw the wall on the balcony using this new style. 

Independent Exercise 

Continue designing the balconies according to the layout shown below. 

 

 

Reviewing the Result 

This completes the modification of the first floor. 

You can now see the final model with correctly adjusted walls, slab, and facade openings. 

10.    Remember: Save your progress under a new file name (for example, Bari_06) to preserve your project 

before moving on to the next steps. 
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7. Workshop: Sections & Level Parameters 

In this workshop, we will create and analyze section views to identify and correct wall connection issues using level 

parameters. 

• Creating A & B section views 

• Identifying problems with wall connections 

• Adjusting Top/Bottom of Structure (TS/BS) parameters 

• Updating all walls via Style Manager 

 

7.1. Creating the Section 

1. Go to the Documentation tab and choose Section. 

2. In the Section Properties dialog, set up the following: 

• Section letter: A 

• Section Type: Image section 

• Representation: Hidden line 

• Hatch on section: switch on 

• Line Thickness: 0.3 mm 

      Tip: You can also choose a vector section if you need a vector drawing. For now, we’ll use an image section for 

faster display performance. 
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Drawing the Cutting Line – Section “A” 

1. Draw the cutting line through the building where you want to see the cross section. 

2. Label it as Section A–A. 

3. Specify the view direction by clicking on the side you want the section to look toward. 
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          Note: The arrows on the cutting line show the direction in which the section is viewed. 

Creating Section “B” 

Repeat the same steps to create Section B–B. 

Both section drawings are now ready. 
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7.2. Inspecting the Section 

Open Section A to review it in detail. You may notice a few issues: 

• The load-bearing walls and partitions are positioned on the base concrete, instead of the load-bearing 

layer. 

• The insulation wall layer does not extend down to the bottom of the slab. 

• The base concrete layer of the slab extends under the load-bearing layer of the exterior wall. 

    Important:  

These construction errors affect how the building transfers loads and maintains insulation continuity. 
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    Important: 

If the section hatch does not match the example shown above, check the Hatch on Section settings in the Material 

Properties dialog to ensure that each wall layer material has the correct hatch pattern assigned. 

 

Using the Cut-Away 3D View/Partial View 

Now switch to Partial View to visualize the problem areas in the 3D model.  

Observe how the walls and insulation layers are positioned relative to the slab. 

   Remember: The 3D cut-away is an excellent diagnostic tool. Use it often to verify the correctness of your 

design before continuing with adjustments. 

 

7.3. Adjusting Level Parameters (TS / BS) and Wall/Slab parameters 

In ARCHLine.XP, we use a parametric level structure. 

In the Level Structure dialog, you can view all parameters linked to the active level. 

These parameters control how the walls and slabs are positioned and connected to the level’s reference points. 

On the right side, you can see the names of the connection points, and their heights can be adjusted using the 

preview image. 

These connection points can later be assigned to wall and slab layers in the Properties Manager. 
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Common Level Parameters 

Code Meaning Description 

FF Floor Finish Level of the top finish layer 

TS Top of Structure Top of the load-bearing layer 

BS Bottom of Structure Bottom of the load-bearing layer 

FS False Ceiling Level of suspended ceiling 

LE Ledge  Extension of the wall insulation layer 

FH Floor Height Total level height 

 

7.3.1.  Solving Problem 1 - Wall Position on the Slab 

As we saw in the section view, the load-bearing walls and partitions are positioned on the base concrete instead of 

the load-bearing layer. 

Now, let’s solve this problem. 

Reviewing the Ground Level 

Now the Ground Floor is the active level. 

Let’s focus on the TS (Top of Structure) and BS (Bottom of Structure) parameters: 
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• TS – Top of Structure: Defines the top of the load-bearing layer. 

• BS – Bottom of Structure: Defines the bottom of the load-bearing layer, relative to the level’s zero height. 

In our case: 

• BS = –300 mm, which is correct because the slab thickness is 300 mm (200 mm concrete + 100 mm base 

concrete). 

• TS = 0 mm, which causes the walls to stand on top of the base concrete instead of the load-bearing layer. 

    Important: 

To correct this, set the TS parameter to –100 mm. 

This ensures the load-bearing layer is positioned exactly one 

base-concrete thickness lower. 

Apply the same TS = –100 mm setting on the 1st Floor as 

well. 

 

 

Adjusting the Slab Position 

When the TS value changes, the slabs automatically shift 100 mm lower. 

To restore their correct position, reset the relative height of the slab to 0 mm on both levels. 

      Tip: 

Always verify slab positions in both section and 3D views after adjusting level parameters. 

This helps ensure consistent wall–slab connections across all levels. 
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Checking the Result 

After the adjustment, the first problem is solved. The walls now rest correctly on the load-bearing structure, as 

intended. 

 

7.3.2. Solving Problem 2 – Wall Insulation Base 

Now we’ll address the second problem, which concerns the bottom of the wall insulation. 

Adjusting the Exterior Wall Insulation Base 

Let’s examine the layer structure of the exterior wall by clicking on one of them. 

Currently, the bottom of the insulation is linked to the TS (Top of Structure) parameter in the Properties dialog. 

This should be changed to BS (Bottom of Structure) so that the insulation layer extends down to the bottom of the 

slab. 

The top of the insulation is already correctly set — it reaches the bottom of the slab on the level above. 

Once the change is complete, update the wall style (Composite brick 300+100 wide) to apply the modification. 

      Tip: 

After applying the change, check the section view — you’ll see that the insulation of the wall now reaches the 

bottom of the slab, as intended. 
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      Tip: 

For better visibility, switch the section view from image to vector mode, then refresh the section by clicking the 

Quick 3D Model icon. 

 

Updating All Exterior Walls 

Switch to the full 3D model to confirm the results. 

You’ll notice that the other exterior walls also need the same adjustment. 

The easiest way to apply it to all of them: 

1. Open the Style Manager on the left panel. 

2. Select the modified wall style (composite brick 300+100 wide). 

3. Right-click and choose “Update all instances.” 

The change is now applied to all exterior walls in the project, except for the balcony parapet walls. 

 

 

Modifying Parapet Walls on Balconies 

Let’s also modify the parapet walls on the balconies. 

Here, too, replace TS (Top of Structure) with BS (Bottom of Structure). 

However, note the difference: 

The wall height is not linked to a connection point but is defined by a fixed value — 1000 mm. 

In this case, the height of the insulation layer must be increased by 200 mm, making the total 1200 mm. 
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After adjusting, update the wall style, and again use “Update all instances” in the Style Manager. 

          Note: 

This ensures consistency across all parapet walls without having to edit each one manually. 

7.3.3.  Solving Problem 3 – Adjust Slab contour 

The base concrete layer of the slab extends under the load-bearing layer of the exterior wall. 

Now, let’s solve this problem. 

We have already modified the slab contour, but now we will adjust only the contour of the base concrete layer. 

This will be done in one step: we will offset it inward by 300 mm, corresponding to the thickness of the brick 

structural layer of the exterior wall. 

Then, for the balconies, we will adjust the contour individually, since the brick wall there is only 200 mm thick. 

7.3.4. Adjusting the Base Concrete Contour 

1. In the Slab Properties dialog, set the displayed layer of the slab to Layer 2 (base concrete). 

 

2. Click on the slab, and from the context menu, choose Edit one layer → Offset All. 

3. Move the cursor toward the interior of the building and enter the offset value: 300 mm. 

      Tip: 

Modify the contour of the base concrete layer of the ground floor slab in the same way as described above, to 

ensure consistency across all levels 

The slab contour is now offset 300 mm inward around the building. 
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7.3.5. Adjusting the Balcony Slabs 

On the balconies, the base concrete contour must be offset back by 100 mm. 

To do this, we’ll use a different editing method: 

1. Click on the balcony slab, and from the marker menu, select the Composite icon. 

2. Click again on the contour, then insert two points using the Insert Node command. 

3. Move the segment between the two points by 100 mm using the Offset command. 

4. Repeat this process for the other three balconies. 

      Tip: 

Using the Insert Node and Offset tools together gives you precise control over local contour adjustments — ideal 

for balconies or irregular slab edges. 
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          Note: 

Don’t forget — in the Slab Properties dialog, set the displayed layer of the slab to Layer 1 (Reinforced Concrete). 

 

Rebuilding the 3D Model 

Once all changes are made, rebuild the entire model in 3D. 

This process updates all geometry and removes any overlapping surface intersections. 

1. Rebuild the model. 

2. Rotate and inspect it in 3D to verify that all surfaces and connections are correct. 

   Remember: 

Always rebuild after major structural adjustments — this keeps the model clean and up to date. 

 

 

Final Check – Section View 

Finally, return to the section view to verify the results. 

You’ll see that the connection points are now correctly formed and that the wall insulation extends properly to 

the slab. 
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Three problems are now solved — the load-bearing walls stand on the load-bearing layer, the insulation reaches 

the bottom of the slab, and the slab layer contour fits perfectly to the exterior walls. 
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8. Workshop 8: Roof Terrace & Coloring 

In this workshop, we will continue modeling on the second level, where we’ll create the roof terrace. 

You will learn how to copy structural elements from the first floor, adjust wall heights, and apply colors using the 

Like painting or grouting option. 

Topics covered: 

• Copying walls and slabs to the 2nd floor 

• Converting it into a roof terrace (1000 mm wall height) 

• Applying materials and coloring walls 

• Using the “Tiling as coloring” option 

 

8.1. Creating the Roof Terrace 

8.1.1.  Copying Walls and Slabs to the Second Floor 

Let’s start by preparing the second level. 

1. Go to the 1st floor plan. 

2. Turn off the layers of all elements except the walls and slab using the Layer Walk command. 

This will make it easier to select only the necessary elements. 

3. Using the selection rectangle, select the walls and slab. 

4. Copy them to the 2nd floor using the Edit Levels dialog. 

      Tip: Turning off unnecessary layers helps you avoid selecting unwanted elements and keeps your workspace 

clean. 
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8.1.2. Converting to a Roof Terrace 

Now let’s turn the copied structure into a roof terrace. 

1. On the 2nd floor, delete all openings (doors and windows). 

To do this, use the Selection by Type command. 

Since this level will serve as a terrace, these elements are not needed here. 

Deleting Partition Walls Using the Selection Menu 

Next, we will delete all 100 mm thick partition walls on the second level. 

For this, we’ll use the Selection menu, which allows you to choose between various selection modes and create 

filters. 

1. Click the Selection menu on the Status Bar and choose Filter. 

2. Set up the filter properties as shown in the figure below. 

3. Delete all 100 mm thick walls that were selected. 

4. Delete the four balcony walls as well. 
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Creating a New Slab (Independent Exercise) 

Since the slab on the first floor was modified for the balcony area, it is easier to delete the copied slab and create a 

new one on the 2nd floor. 

You will need to redraw both the Slab Contour and the Base Concrete Contour — this can be done quickly using 

the Offset All option. 

Also, create the staircase opening at this stage. 

      Tip: Using the Offset All option allows you to generate both contours quickly and precisely. 

Using the methods you have already learned, perform these steps to complete the new slab. 

          Note: 

Don’t forget to set the TS parameter of the 2nd level to –100 mm, and the Base elevation of the slab to 0 mm. 
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Defining the Wall Style with 1400 mm Height 

For the exterior walls, we will use terrace parapet walls with a height of 1400 mm. 

The easiest way to achieve this is to create a new wall style based on the existing Composite brick 300+100 wide 

wall type, and then replace the exterior walls with this new style. 

1. Click on one of the exterior walls in the floor plan. 

2. Modify the height parameters by layer as shown in the figure. 

3. Save the new wall style as Composite brick 300+100 wide 1400 height. 

 

4. Turn off the Wall – Partition wall layer using the Layer Walk icon. 

5. In the Style tool palette on the left, select the new wall style, right-click, and choose Replace. 

6. Select all exterior walls to apply the new style. 

7. Turn the Wall – Partition Wall layer back on. 
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Staircase Exit (Independent Exercise) 

Using the methods you have already learned, create the staircase exit to the roof terrace as shown in the reference 

image. Then, place the staircase roof slab on the third level. 

  

Review the result in 3D view. 

1. Switch to 3D view and review the result. 

You should now see the completed roof terrace. 

2. Using the Ribbon Bar → View → Animation → Walk and Fly → Rotate around command rotate the model 

to examine it from all angles. 

 

8.2. Coloring the Building 

Next, we will apply colors and materials to the exterior surfaces of the building. 
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In this exercise, we will first create a new material based on a custom color — Deep Orange — and then apply it to 

the terrace and balcony walls. 

8.2.1. Creating a New Material 

1. Open the Design Center → Materials panel. 

2. Click the black gear icon and select Create Material. 

 

3. In the Material Properties dialog, open the Appearance tab and click New Material. 

4. In the Custom Color table, set the RGB parameters as follows: R: 148, G: 25, B: 4 
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5. Save the material with the name Deep Orange in the Material Library → Colors → RGB subcategory. 

 

You have now successfully created the Deep Orange material. 

8.2.2. Applying the New Material 

1. Make sure the 3D View is active. 

2. In the Design Center, select the Deep Orange material. 

3. Drag and drop the material onto the balcony and terrace wall surfaces. 

4. In the dialog that appears, choose the Like painting or grouting option. 

          Note: 

The Like painting or grouting option allows you to recolor walls quickly without altering their structural properties. 
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8.2.3.  Finalizing the Roof Terrace 

Once the color is applied, check the results in 3D view. 

Rotate the model to observe how the colors interact with the surfaces. 

You have now completed the roof terrace and coloring stage. 
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9. Workshop: Documentation 

In this workshop, we’ll prepare the final project documentation. 

You’ll learn how to create dimension drawings, add room stamps, apply color schemes, and prepare sheets for 

printing. 

• Setting up dimension styles 

• Automatic placement of room stamps 

• Applying color schemes by apartment 

• Adding callouts for detailed drawings 

• Creating elevations and Section Views 

• Plot Layouts and Printing Multi-Page PDF 

• Updating layouts automatically 

 

9.1. Setting Up Dimensions 

Let’s continue working with dimensions. 

1. First, check the properties of the dimensions. 

2. Go to the Building Dimension and set the dimension style. 

3. Choose the “External wall” style. 
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Now take a closer look at what this style includes — notice the parallel dimensions, and how the windows and 

doors are dimensioned. 

 

This setup will be suitable for our project. 

From now on, we will use this style to dimension all external walls. 

      Tipp: Dimension styles allow you to maintain consistency across your drawings. Once you find a configuration 

that works, save it for future projects. 
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9.2. Placing Room Stamps 

Next, we’ll place room stamps. 

The properties of a room stamp can be preset and saved as a style. Select the appropriate style from the list. 

1. Use the “Automatic Room Creation” command to place all room stamps on this level in one step. 

2. There are four apartments on this floor. 

3. In the first apartment, rename the room names to their correct values. 

          Note: Automatic placement saves a lot of time when you’re working with multi-apartment projects. 
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Setting Apartment Properties 

In the Room Properties dialog, set this room to belong to the first apartment. 

Then copy this property to the other rooms of the same apartment. 

Repeat this process for the other apartments as well. 

      Tipp: You can use the Property Painter tool to copy room attributes quickly between similar rooms. 

 

9.3. Applying Color Schemes 

Now that all room stamps are ready, let’s visually organize the apartments. 

We will use a Color Scheme to display rooms belonging to the same apartment in matching colors. 

Color schemes let you display rooms in different colors based on various criteria — for example, gross area, net 

area, or apartment grouping. 

In this case, we’ll color-code the rooms of the four apartments and the staircase with different colors. 

Repeat this setup on the first floor as well. 

    Important: Use color schemes only for visual presentation — they don’t affect any physical model properties. 
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9.4. Creating Callouts for Details 

Let’s continue the documentation by turning off the Color Scheme display temporarily. 

To show a detailed part of the drawing, use the Callout command. 

1. Adjust the Callout properties. 

2. Draw a rectangle around the part you want to highlight. 

3. The program creates a new view for this detail automatically. 

4. Replace its content with a suitable detail drawing or image. 

In this example, we’ve inserted an image showing the window structure detail. 

      Tipp: Callouts are great for referencing details — they automatically stay linked to the main drawing. 
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9.5. Creating Elevations and Section Views 

Now let’s turn on the sections and the cutaway view we have already created. 

These will form part of our project documentation. 

Next, we’ll move on to creating elevation views. 

1. Set the properties of the elevation views. 

2. Choose Textured representation to display materials more realistically. 

3. Generate the elevation views one by one — for example, the North, South, East, and West facades. 

Check one of the elevations to verify that it displays correctly. 

At this point, we have completed both the section and elevation views. 

      Tipp: Consistent elevation naming (e.g., East Elevation – Courtyard side) helps keep your documentation 

organized when you prepare print layouts. 
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9.6. Plot Layouts and Printing Multi-Page PDF 

9.6.1.  Creating Plot Layouts 

Now let’s prepare the plot layouts for printing. 

1. Select the sheet size — choose A3 landscape. 

2. Specify how many plan sheets will appear in one Print Layout View — in this case, eight. 

3. Select the appropriate title block (stamp). 

4. The program then automatically creates the Print Layout View containing eight plan sheets. 

          Note: Each plan sheet represents one printable drawing — for example, a floor plan, section, or elevation. 
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9.6.2.  Placing Drawings on the Sheets 

From the Project Navigator, drag the drawings onto the layout sheets one by one, selecting the appropriate scale. 

We’ll use a 1:100 scale here. 

1. Place the floor plans first. 

2. Then add the sections. 

3. Finally, place the elevations. 

      Tipp: When positioning drawings, align them carefully on each sheet — this helps achieve a clean, professional 

look in your printed documentation. 

 

 

9.6.3.  Printing to a Multi-Page PDF 

Next, let’s create a print queue to produce a single multi-page PDF. 

1. Choose the Print Layout View containing the eight sheets. 

2. Set the printing parameters: 

• Paper size: A3 

• Orientation: Landscape 

• Scale: 1:1 

• Rotation: None 

• Position: Centered 

• File name: e.g., Bari_residential_park.pdf 

3. Click Apply — the program will copy these parameters to all sheets. 

    Important: Always verify the print scale and orientation before exporting to PDF to avoid misaligned or 

cropped drawings. 

Now print all eight sheets into a combined PDF and check each page. 
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You’ve now generated a complete documentation package in one file. 

 

 

9.7.  Updating Layouts  

9.7.1.  Updating Layouts After Model Changes 

Let’s test how the documentation responds to model updates. 

In the elevation view, change some surfaces from Deep Orange (RAL) to Light Ivory. 

You’ll notice that all views in the project automatically reflect this change. 

To update the printed sheets: 

1. Click on any drawing on the plot layout. 

2. Select Refresh All Layouts. 
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3. The content of each sheet will be updated instantly. 

   Remember: Keeping your layouts refreshed ensures that your printed documentation always matches your 

current model. 

 

9.7.2.  Displaying Color Schemes on Layouts 

As a final example, let’s show how to display the color scheme on the layout even if it’s turned off in the plan view. 

1. Open the plan sheet where you want to show colors. 

2. In the drawing’s Properties, under Color Scheme, select the previously used scheme style. 

The sheet now displays the apartments in color, while the model view remains unaffected. 

      Tipp: You can use different visual settings for model views and layouts to make your documentation clearer 

and more visually appealing. 

 

With this, you’ve completed Workshop 9 – Documentation. 

You now know how to: 

• Dimension external walls 

• Place and group rooms by apartment 

• Apply color schemes 

• Add callouts and detail views 

• Create and print full documentation sets 

• Automatically update layouts after any design change 
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10. Workshop 10: Environment & Rendering  

In this workshop, we complete the project by modeling its surroundings and creating presentation materials. 

You will learn how to add vegetation and render photorealistic images. 

• Adding surroundings: fences, gardens, trees 

• Saving perspective views 

• Creating photorealistic renders with background images 

• Using progressive rendering and noise filtering 

 

10.1. Creating the Environment 

Let’s continue the modeling process by creating the building’s environment. 

1. Display only the environmental level in the 3D view. 

2. Load the prepared garden that belongs to the building — it includes the stairs and fences, but no plants 

yet. 

3. Show the entire building again and rotate it to review the overall composition. 

      Tipp: Keeping the model lightweight at this stage helps you adjust surroundings more easily before adding 

vegetation or detailed objects. 

 

10.1.1. Adding Trees and Plants 

Next, we’ll add natural elements to complete the outdoor setting. 

1. Open the Library and place trees and plants around the building. 

2. Use a mix of species and sizes for a more realistic result. 

3. You can duplicate and rotate individual plants to create a natural variation. 

          Note: The vegetation objects in the library already include basic 3D geometry optimized for rendering — no 

need for manual adjustments. 
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10.1.2. Saving Perspective Views 

In the Perspective dialog, we’ve already set up and saved several viewpoints. 

You can easily switch between these perspectives using the arrows displayed on the 3D view. 

      Tipp: Always save multiple perspectives — front, corner, and aerial views — to quickly compare lighting and 

camera effects before rendering. 
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10.2. Creating Photorealistic Renders 

Now let’s create a photorealistic render from one of the saved perspectives. 

1. Select the desired view. 

2. Set the resolution to Full HD (1920×1080). 

3. Choose the Q2 quality setting — high-quality but fast to calculate. 

4. Add a background image that complements your scene. 

5. Start the rendering process. 

Rendering setup is simple, and the process itself is fast and easy to learn. 

The rendering engine uses a progressive rendering method, which refines the image step by step until it reaches 

the desired quality. 

Once the render is complete, the image is saved automatically. 

    Important: Avoid using extremely large image resolutions unless necessary — they may increase rendering 

time significantly. 
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10.3. Applying Noise Filtering 

Select another saved view and render it as well. 

After rendering is complete, the noise filter automatically cleans the image, removing any graininess or blotchiness 

from the scene. 

The result is a smooth, clear render with well-defined details. 

Save this second image and review both renders. 

      Tipp: Noise filtering is especially useful when rendering scenes with artificial lighting or low-light conditions. 
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11. Workshop: Managing Multiple Buildings 

In this workshop, we focus on handling projects that include multiple buildings. 

You will learn how to create, duplicate, and manage several building structures within a single project, ensuring 

that each stays organized and coordinated throughout the design process. 

• Copying and placing additional buildings (to reach four) 

• Presenting the final animation in D5 Render 

11.1. Duplicating and Placing Additional Buildings 

In this residential park, there are four buildings in total. 

We’ve modeled only one so far, so let’s create the remaining three. 

1. Open the Levels dialog. 

2. In the Building List, create three additional logical buildings. 

3. All buildings share the same level structure as the first one. 

4. The active building is always the one currently selected — at the moment, that’s Building 1. 

          Note: Keeping building structures consistent ensures that copied elements align perfectly across the entire site. 

 

11.1.1. Copying the First Building 

1. We’ve already defined the locations for the other buildings on the site plan. 

2. Select all levels of Building 1 and copy them using a reference point. 

3. Activate Building 2, then paste the copied structure at the predefined reference location. 

You’ll notice that Building 1 turns gray, indicating it’s now inactive, while Building 2 is active and ready for editing. 

Building 2 is now active and ready for editing. 
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11.1.2. Adjusting Colors 

Change the color scheme of Building 2 to the appropriate color, and repeat the process for Buildings 3 and 4. 

After completing these steps, all four buildings of the residential park are ready. 

      Tipp: Varying façade colors slightly between buildings helps the complex look more dynamic and realistic in 

renders. 
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11.2. Rendering and Presentation 

All four buildings are now in place. 

Let’s explore some of the saved perspectives and review the final rendered images. 

In D5 Render (using the ARCHLine.XP–D5 Plugin), we can also create a walkthrough animation of the residential 

park — complete with lighting effects and camera paths. 

   Remember: D5 Render allows real-time visualization, so you can explore the project interactively. 
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